Ad delivery degradation in the Americas region

Incident Report for Equativ Monetization

Resolved

Dear Customers,

We are pleased to inform you that the issue affecting ad delivery and impression volumes in the Americas region on our Monetization Platform (EMP) has been fully resolved.

Our technical teams have confirmed that all systems are stable, and we will continue to monitor the delivery closely to ensure optimal service.

Start date & time: April 4th, 2026, at 04:00 AM UTC
End date & time: April 4th, 2026, at 09:30 PM UTC

Thank you for your patience during this time.

#inc-1483
Posted Apr 06, 2026 - 09:22 UTC

Identified

Dear Customers,

We have identified an issue with the ad delivery on our Monetization Platform (EMP) in the Americas region. There may be a reduction in the number of impressions in the affected region. Our team is working to resolve the issue as soon as possible.

Start date & time: April 4th, 2026, at 04:00 AM UTC

We apologize for the inconvenience caused. Thank you for your patience.

#inc-1483
Posted Apr 06, 2026 - 09:18 UTC
This incident affected: Delivery US.